"Something went wrong" message

I used my Anova Precision Cooker today. Upon starting the app on my iPhone, I get a “Something went wrong” message.

I tried signing in using my email address and password; it does not seem to be working.

I verified the email address and password combination via the Anova web site.

I also tried removing the app from my iPhone and downloading once again to no avail.

Have you seen this error message previously?

Thanks in advance,

Hi Angelo! Sorry about this. Not sure what this may be, probably best to have tech support take a look! Can you email support@anovaculinary.com? We will get you fixed up ASAP!

Thanks for the prompt reply. I sent an email earlier today. Also, I left a voice mail with this issue.


Welcome @anyeguevara

I too have seen SOMETHING WENT WRONG. I changed my ‘machine’ from my iPhone to my iPad and connected promptly.

I don’t know what was the difference other than time. I live on a really iffy slow DSL - WiFi connection, and that may have made the difference - trying again a few minutes later.