This beeping is driving me crazy!

I’ve seen several posts from other owners who complain about constant, random beeping, but the only solution I’ve seen put forward, unplugging and plugging the device back in, won’t stop the beeping. I recorded a ~2 minute video to help diagnose the problem. I tried capturing multiple angles of my setup, that’s why I keep moving the camera around. ANY help would be greatly appreciated. 

FYI, an hour into cooking it’s still beeping.

The Anova circulator is supposed to beep whenever it hits target temp, notice how the beeping is tied to when it senses the water temp being equal to the set temp of 130?  That’s normal.  What’s not normal is how fast the temps are swinging up and down for such a large container.  Those polycarbonate containers shouldn’t lose heat that fast.

I don’t hear the circulator impeller (pump) motor running though, nor do I see anything that looks like water movement around the 00:32 mark.  Is the impeller running?  It could just be the video.  If you can’t tell / or aren’t sure, set the temp to as low as it will go then turn the unit on.  The heater won’t kick on, but the impeller should run, since it’s not heating, you can stick your hand in the water and feel the output jet around the bottom of the unit.  It’s a pretty powerful jet of water, it should be easy to feel.

If that isn’t it, it could be the temp circuit is borked. You can check this with an seperate thermometer probe in the tank.

In either case, you probably will have to RMA the unit or return for exchange at the place of purchase if it is new.

Mine has always had the problem. Most of the time unplugging usually work but there are times it never worked and it’s so annoying. Ive been following some reviews on several websites that i found on  and so many people seem to be having this problem. No one seems to have found a parmanent solution for it though. Am hopping the company must ave received such complains and are expecting announcement of improvement on new products, cause am thinking of buying another one asap.

Yep, I’d say that unit is defective and should be returned or RMA’d if you’re outside of the retailer’s return period.  The temperature really shouldn’t be changing that quickly (mine doesn’t).

Thanks ACS and fischersd, your comments were very helpful. Now I know that it is indeed, faulty. That was the first time using it, so yes it’s new. We bought it from Amazon, so it shouldn’t be too difficult getting it replaced. Thanks again!

And Heather, yeah you would think they would officially respond to similar complaints, and at least let people know they have a faulty unit. That beeping can get pretty annoying!!

If anyone cares, the beeping problems aside, the steaks it produced were delicious!  

Anova was pretty good when it happened to mine. But they do make you jump through the hoops a bit.

Thanks folks. This is happening to mine too. I’ll try some troubleshooting then contact Anova.

Here is the permanent fix.