touch screen doesn't work

got my anova pro today. the touch screen doesn’t respond. has any one had this problem?

1 Like

If there is a problem your best option is to contact support. It will be the fastest way to get things sorted.

I already did, waiting for reply,

I have the same problem, was there a fix for you?

They do not repair, apparently it is cheaper to replace the unit, so they had sent me a new one.

Same here, “Pro” just out of the box, only the ‘+’ button works.
If I remove the shield, i can sometimes use the network button.
Hope the replacement they said they would send does not have this problem.

Hey all,

I’ve had the exact same thing happen, brand new pro out of the box… pretty much only the arrow buttons working… others can very rarely work if forced…
I contacted support, I hope my replacement works… because this sounds like it could be a fairly common fault!

Hey Jhammarback,

Did your replacement work fine?

Same deal. Plus terrible online chat communication

It does not have to be a hardware problem, it might as well be software. Try to update to the latest device software if not already done.
If it is difficult to even get into pairing mode then try with moist/wet fingers and make sure to wait about 10 seconds before the first press to give time for initial touch sensitivity calibration.

1 Like

We ordered the PRO model thru Amazon. Arrived and set up. Worked once. Then the touchpad was zero responsive. Amazon sent a replacement. D.O.A. So we backed off the PRO and have since bought the Precision WiFi. We now have two of those and it lets us Sous Vide at two different temps simultaneously.

I just open the ANOVA PRO and the sreen was working fine. I connected the mobile and I updated to the new fimware and the screen stop working. Waiting for refund, Im so disappointed with this brand.

1 Like

Anova is pathetic. Ordered directly from them and same problem out of the box.

So do i… just got new anova pro out of the box, but no touch display work. i have 4 anova, all of them have problems, when they resend it i have to pay another import tax… anova is pathetic.

I have exactly the same problem, where only the “+” seems to work. Did the replacement they sent through work? As this seems to be a common problem.

The anova pro is not properly grounded … use an adaptor with ground for the plug if needed…

moistening the finder solved it !!

Wtf, to update firmware, you need to click on the keypad. Which is not working!