Water Not Heating

I have the wifi model and am trying to do my second cook tonight. Everything went fine the first time, after I got past the ridiculous wifi issue of not being able to connect to a network that has spaces in the name, but on tonight’s cook the unit doesn’t seem to be working.

Over the course of the last 45 minutes or so I’ve watched my water temperature steadily drop by about a tenth of a degree every ten or fifteen seconds. I’ve done everything I know to do to try to get it working again, but something seems to be wrong here. It’s really disappointing to have this kind of problem on my second cook, and of course now my supper plans will have to change.

Has anyone seen this kind of issue with the unit not heating the water?

Replying to my own thread here. After having this much trouble and only being on my second cook, I’ve decided to return the unit to Amazon and get the Joule instead. I am not confident that a replacement unit will work any better than this one.

Hi @sportsman,

Just to get a clear picture of the issue… you set APC to the desired temp, the water heats to that temp, and once the temp is reached it starts to drop a tenth of a degree every 10 or 15 seconds? Or are you starting off with a water bath that is already hot (I do this), and then are sticking the APC in and watching the temp drop? Also, am I right in assuming that you are setting the temp manually and hitting the start on the unit manually - removing any potential problem issues with “connectivity” from the equation?

The more info you can provide the better the chances folks here can help! And it wouldn’t hurt to go ahead and contact Anova support right away in case they are familiar with your problem.

Thanks for the response. I started with the water at about 135 degrees (measured with an instant-read thermometer) and set the unit to 144 degrees, then turned it on. Over the course of about an hour, it dropped to around 115 degrees, which is when I gave up. I added hot water twice, but it quickly dropped back down. My instant-read thermometer registered within a tenth of a degree of the temperature on the unit every time I checked it.

I believe the heating element is defective. After I gave up, I took the metal sleeve off of the unit and touched the heating rods; they were only barely warm to the touch, as they would have been after being in the water.

I tried setting the temperature from the iPhone app, and I also tried doing it manually. At one point, I cleared all network settings from the Anova unit and went totally manual, but it still did not heat the water. It’s pretty clear to me that the unit is defective.

I have very little confidence that I can count on a replacement unit to last very long. I had planned to use it frequently, so I’ve decided to give the other popular manufacture a try instead.

Sounds like you approached the problem well. I’ve had my Anova for the last four months and have been using it a lot, with no problems. Unfortunately it sounds like you did get a bad unit. Going with a Joule is definitely an option. From what I’ve researched it is also a quality choice. Just be aware that there are people who have had this same kind of issue with the Joule as well. Regardless which immersion cooker you choose there’s the chance you’ll get a lemon. I’m pretty sure that the Anova has at least as good of a record as the Joule, but since the Anova does not require connectivity with my phone to let me use it the Anova is my “unit of choice”! :slight_smile:
You still might want to run the problem by Anova support, just in case the issue can be resolved with a “reset” or something. Good luck however you proceed!