Wifi with AVM FritzBox Router

Hello,
I’m not able to connect my Anova to Wifi. After reading the troubleshooting I’m
recognized that the Wifi password should (or needs) be 8-18 characters in lengths.
I’m using a AVM Fritzbox router which is very popular and the market leader in germany.
Each FritzBox comes with an individual 20 digit long password (sure you could change if
you want). I use this 20 digit password and is this the reason for my problem ?
Any FritzBox user here in the community to confirm my assumption ?
Would be really silly to change the password cause I’m using round 'bout 20 Wifi devices
within this network and I have to reconnect all of them just for the limitation of Anova.

Thanx in advance, Dirk.

1 Like

Hi Dirk,

my Anova is connected to a Fritzbox 7490 with a >30 digit password with WPA2 (CCMP).

For pairing please disable 5 GHz in you Frizbox, connect your Anova, then you can enable 5 GHz back again. --> WLAN - Funknetz - uncheck 5-GHZ Frequenzband - übernehmen

Cheers Michael

1 Like

Thanks @MrBeta!

Hello Michael,

thanx for your feedback.I deactivated the 5 Ghz also to be sure. Connection failed. I placed the Anova bout 20 cm beside my FritzBox. Connection failed. In the meantime I got response from Peter from Anova:

Greetings! Yes, you’ll need to setup a 8-18 character WiFi password. The cooker has limited hardware and can only store so much data.

Wondering how you managed to get this working:-)
Never less I changed my password to 16 digits and… Connection failed.
I placed the Anova 20cm beside the router. Connection failed.
Then I uninstalled the App und reset the Anova Wifi. Restart new and… Connection failed.
So I’m afraid I have to discuss in detail with the support.

CU, Dirk.

Arghh that sucks you’re having a hard time connecting - sorry about that. Yeah, support will be able to troubleshoot and help get you connected. Definitely contact them!

Hi Dirk,

I have exactly the same problem with my Fritz Box 6360. Simply don’t get any connection. Have you been successful?

Best,

Olli

Hello Olli,

I’m in contact with the support and we’ve tried a couple of things within the router configuration. But still Connection failed. Today I will try it again wit another smartphone. If we have any progress I will share the information.

CU, Dirk.

Perfect - many thanks. Btw I tried it with an iPhone 6 and Samsung Android S7.Both didn’t work.

Hello again Olli,

just curious. What’s the length of your Wifi password ?
Tried with 18 or less characters ?

TIA, Dirk.

Hi Dirk,

Yes it is a 16 digit number.

Best,

Oliver

Hi Dirk,

Any progress on your side?

Regards,

Oliver

Hello,

walked through all configurations and changing a couple of things in the router but with no success. Now it seems that the Anova itself is the problem. I will get another one and will try it again.

I just got my Wifi cooker to germany.
and have the exact same problem like you with FRITZBOX 6390

No Wifi Connection possible!

Cooker is placed 30 cm besides Fritzbox Router
(App and bluetooth with IOS/Iphone 7 works fine)

I tried even with the change to a 8 character Password (only numbers in it)

and also the very strange adivce of Mr BETA (disabling 5ghz) --> no success (as expected, as he HAD obviously to be not telling the truth as the support says the password has the max of 18 characters HARDcoded!! and he claims to work with even a 30 character PW )

The Wifi Eventlog of Fritzbox always says connction failed due to “invalid password”

Is it really a hardware problem that can be fixed with an exchange?

I had the exact same problem with my Wfii cooker and a Fritz!Box 7430.
I tried changing the password, auth method and so on. Nothing seemed to work.
Today I changed my SSID from “FRITZ!Box 7430 OM” to “FRITZBox” (no spaces and no !) and it worked.
I could even use the default 20 character password.

Wasn´t helpful here, had SSID from the beginning changed to a short character word with no spaces an no !

still no success

Wth …

Got mine today and no way to connect to 2,4 GHz.
Maybe cause of * in password …

Also my ssid has spaces in it …

Very poor technical excellence in iot age …

Maybe i will setup a new WiFi ssd access point with ann10 year old 7170 or 7270 / 7240 which is down in my cellar to get this working …

Or maybe an firmware update incoming soon ???

So I have a FritzBox 7490 and have not been able to connect. I disabled the 5GHz network. Created a guest network that meets the WiFi requirements. SSID is visible, all lowercase, 10 characters long and no spaces. Password is 10 characters long, 9 lowercase letters and a number. Does it matter that the network is WPA2(CCMP)?

So what is the deal here, is my Anova defective? Not compatible with my FritzBox?

What is the deal with those WiFi requirements? The only one of those requirements I find the least bit acceptable is that it can’t connect to a 5GHz network. The rest are, frankly, ridiculous.

Have you tried reaching out to support@anovaculinary.com?