Oven randomly shuts off after latest firmware

After updating to 1.4.18, my APO won’t stay on, typically the oven will turn itself off after approx. 2hrs. It also doesn’t consistently reach the temperature that was set in the app.

Has anyone else encountered similar issues after the firmware update?

1 Like

Yes, also having this. I’ve just emailed support about it. I’ll be pleased if it’s just a firmware issue, was worried it was hardware.

I have the same problem.
Oven turns itself off. Sometimes even before it reaches the set temparature.
Started happening after the last Firmware update.

I have the same. Oven restarts during cooking and sets temperature to 65.6c and timer to 0:00. It does’nt switch off. Contacted support, they suggested reset, will try today.

Yes, this is happening to me as well.

After factory reset (pushed button for WiFi and Start for 8 seconds as suggested by support), connect oven to app again from scratch, application on the phone reported 1.2 version (it was shown before 1.4.1.8), upgraded, for now, it works…

Didn’t help. After successfully finished one bake, oven restarted and reinitialize to factory…contacted support, waiting for feedback.

Same for me. Don’t see a pattern. It’s happened 3 times so far at different times.

My oven just updated to 1.4.21, I’m not sure what’s in it but maybe it will address the random shutoffs.

I got the updated firmware as well (1.4.21) but the temperature still continuously drops after any new stage is activated or even the door opening and closing. I have to stop it and start it again to get it to heat up. It dropped from 473 down to 350 degrees before I could get it heating again. Oven is useless this way, let me go back to the old Firmware which worked fine.

I just did the firmware update and my oven keeps turning off randomly, which is a real pain.

Seems to be no rhyme or reason to it.

Support sent me instructions to turn off the oven overnight, then factory reset, which I did. An initial cook finished fine, but it looked like the oven had restarted itself the following night, came back in the morning to the temperature being 65.3C/150F. Update to 1.4.21 took place and did two long cooks yesterday and today with no issue so far, so fingers crossed that’s done the job.

Just to update… after support advises firmware update, problems with restarting not happened (I did multiple batches of bread and other stuff. So, happy me. :slight_smile:

I just did the update and my first run failed. Sounds like yours did too but then started running ok. Still the case?

Yes, no issues since updating to latest firmware.

After just under a year of ownership, the oven is switching itself off randomly in the middle of cooks. Just now was the first time I was watching while it happened, the rear fan, element and light power off. The display and case fan stay on. A couple of seconds later, the display glitches and powers off with a beep. Case fan remains on indefinitely. Haven’t tried a reset yet, that’s going to be the first step once this cook actually completes properly.

I found this happen to me today while roasting some turkey parts @ 450. The oven just shut off after 15 minutes. It was dead, no lights or anything. Unplugging and plugging in again didn’t help. Eventually it just came back on after a couple minutes. I started it up again and it died the same way in 7 minutes.

I attempted a factory reset on it, but the only thing that did was ensure it would never again connect to wifi.

this shutoff during a cook happened to me last night. my oven is over 2 years old and was running firmware version 1.1.10. we always unplug the after use so the firmware never has a chance to auto-update while idle hence the old version. so i jumped on this thread to read about the problem.
funny that i had the issue while running such an old version and that the problem appeared so late.
so i updated to 1.4.21.
question:
the complaints seem to have quieted down, is anyone still having this problem? or has the problem gone away for everyone?
is it now considered fixed?
thanks in advance!

no issue after latest update

Same with me. Seems to be related to “high” temperatures and looks like a thermal protection is tripping.

Did you get it resolved?