Timer countdown on the app doesn't move during cooking

Hi folks - I have used my cooker twice now (the steaks were great, the poached eggs were strange) and each time noticed that while using the iPhone app - it was tracking temperature, but the timer didn’t count down, just stayed static on the cooking time.  The device itself showed the timer counting down - but isn’t the point of the app so that you can keep an eye on things without hovering over the cooker ?  I am a huge nerd, so the app functionality was a major deciding factor when I made this purchase - is it just buggy or am I doing something wrong ?

I got the app and tried it once. I went outside the Bluetooth range while working out back and lost connection.

I will try it again this weekend to see how the timer works. I have a timer from Thermoworks that I use for everything and never explored the built in timer. It hangs from my neck and I can go anywhere and see how long I have to go for my cooking session. They make  one that has 3 timers that you can see all at once. I have been thinking of upgrading.

Or you can use your phone and get an app. I have a Samsung Galaxy S4, I hit the mic icon and say “set timer 1 hour” (for example). It can track multiple times easily, plus it’s my phone so I always have it on me.

Same problem for me. I’m using Iphone 6. The app allows temperature to be set but it doesnt allow/show countdown timer. Or does it do countdown in the first place?

Little bit of a late reply but - The way it is supposed to work is as follows:

Two types of cooks: Manual and Preset via Recipe

Manual: Choose temperature, choose time.
Timer will start once the water hits the desired temperature - you must manually hit the “OK” prompt when the device reaches temp to start the temperature. Keep in mind that the timer operates in minutes, so you won’t see the countdown for the first minute.

PreSet: Choose recipe, hit Play.
Timer will work the same as the manual function. It won’t “start” until you accept the prompt that pops up after the device hits the required temperature 

Hope that clarifies a bit.

If this isn’t your experience, please let me know here or via our support channels (chat, fb, twitter, email) and we’ll help you get straightened out :slight_smile:

I have an iPhone 6. I have the same problem with the timer’s not working. This is a bug that should be able to be fixed.

Yes the timer is a total joke. Deeply disappointed in the crappy software installed on this cooker. The timer goes down by 2 or 3 seconds and then stops. The app software is totally useless, since it won’t let you do anything about that. Oh you can change the timer start amount. Oh you can change it again. It’s a joke. Overall, the documentation for this product is terrible, awful, bloody bad. I probably have other adjectives for it but they are polite.


There is no prompt that pops up when the thing hits the temperature. It makes no effort to tell me that I need to start the timer, and why the devil isn’t there a button on the device so I can drop the food in and hit start timer? What if people aren’t carrying a cell phone around with them for god sakes can you imagine a world where everybody didn’t carry a cell phone??? I can

The problem may just as likely be a lag on your WiFi or internet connection. Or your phone. Seems to work fine for me, the few times I’ve tried it.

No even after 15 or 20 minutes, it is still only moved a few seconds. Not lag issue

I’ve been having the same issues with the timer resetting to zero in the Android app since day one.

Oddly, on my current 48-hour cook, the timer is working perfectly. In fact, the timer comes back when switching from home Wi-Fi to cellular to work Wi-Fi newtorks :slight_smile:

It’s been working properly for >18 hours now. Not sure what changed, but I’m happy and hope it keeps working :slight_smile:

Will report back it eventually breaks :wink:


1 Like

Hi. I just bought this week a Brand new Anova

Hi. I bought a brand new anova precision cooker Nano and using it the second time the timer stopped (both on the device itself and on the iPhone) while the temperature has been reached. So I have the same issue. What to do?

Contact Anova Support