Unit not working - 3 beeps - reads a high temp

Hi there - need urgent help. Halfway through a 10 Hour cook! Unit was set to 77c (170f) I think I saw a -10 reading at one point but figured it was a glitch or drop in temp from adding more water. Now it reads 207.1 (which the water is not) and lurches a half turn and stops to then emit 3 successive beeps.

Only had the unit a few months and used 5 times maybe…Not a happy Bunny Anova. Please help


Contact Support at support@anovaculinary.com

The will get you going.

@geemcwee, I’ve had a similar experience once, the good news is that if it’s what I think it is, there’s an easy fix.

Twist the Anova around in it’s mount so that the scroll wheel is not over the water bath. Put a lid (cling wrap, aluminium foil, a cutting board, whatever) to cover the cooking water vessel, and see if you can position the whole lot in an area with a bit of air-flow. The ceiling extractor fan in my kitchen was enough to make all the difference. Excessive condensation is the culprit, and these easy fixes should get you going again in no time. 

ps Love the username!
1 Like

thanks for the pointers guys - any idea on how to firstly get the unit back working - been 2 days and still the same?

We developed the same problem today.

I tried Simon_C’s suggestions: (He says Excessive condensation is the culprit).

Twisted the Anova around in its mount, covered the cooking water vessel, turned on the fan, unplugged and re-plugged the ANOVA.

The temperature swings decreased, and the 3 beeps stopped for 15 minutes. They just restarted, every 15-30 s. So will try this again…