Wifi connection issues

Hi,

I’m using an Apple Airport Express and I can’t seem to be able to connect to my Anova with wifi. The bluetooth works fine, but the wifi just doesn’t work at all.

  • I tried resetting Anova and uninstall and reinstall app.
  • I separated my wifi so that I have a 2.4ghz and a 5ghz and I connect to the 2.4ghz.
  • Support is telling me that my client isolation or ap isolation is enabled but I have no idea how to disable it.
  • I’ve tried every setting and option that I can do on my airport express, but nothing seems to work.

What am I doing wrong and why is it so hard to make sure that you’re connected to the wifi?

Thanks!
Dennis

Quick question. When trying to connect to the 2.4 GHz WiFi on your Apple Airport Express are you right next to the router? In the instructions they tell you to do the set up within 5 feet of the router. You will not have to operate it within 5 feet, just set it up within 5 feet.

As for Client Isolation or AP Isolation on the Airport routers. I use an Airport Extreme Time Capsule, so I am familiar with the app. When you separated the WiFi did you turn on the guest network? If so, are you trying to link to the guest network rather than the normal network? In my case when I separated my networks for 2.4 and 5 GHz, I got one named NETWORK and one named NETWORK 5 GHz.

If you don’t use the guest network, I suggest turning it off because it has client isolation always on.

AirPort Utility > Select the AirPort > Edit > Wireless tab > Enable Guest Network

1 Like

Hi @SouthernDad,
Correct, I’ve literally placed it next to the router so it can’t be that. I’ve also ensured that the guest network is off so I really don’t know what to do here and how to make sure the wifi works :confused:

Yeah, made sure I connected to the right network as well and not the 5 ghz one.

Another question to think about. Does your WiFi password have any special characters in it? It can only be numbers and letters.

Yeah, I thought about that too. My password only contains letters and numbers and no special characters :confused:

…and no spaces and it’s 19 characters or less, right?

Which iPhone and iOS version are you running?

You did forget the network and re-add it on the iPhone after setting up the 2.4GHz and 5GHz networks right?

(maybe not a bad idea to go through that again, just to make sure there’s no “type-o’s” with the network password).

And the two networks have unique SSID’s?

Have you gone through the wifi troubleshooting doc?

2 Likes

ALL I CAN SAY IS THAT IT SHOULD NOT BE THIS HARD TO CONNECT THE WIFI! The amount of resetting and reconfiguring and rebooting and restarting and all that is RIDICULOUS! I am not a novice - I have administered networks and have installed a number of smart devices - and this device is RIDICULOUS! So pissed that I spent the extra $50 to get the wifi version of Anova.

1 Like

@jgabelhudson see my response to your thread.

I am having the same issues. I have turned off 5Ghz and restarted everything, deleted, reinstalled…repeatedly. No luck.

Hey @Randy_Werner please reach out to customer support if you haven’t already. They’ll dig a little deeper for you and help get you connected.

Success with Anova and Airport Extreme!

After a mind numbing number days I have it connected:
The first couple of attempts following instructions provided by Anova support failed, but here is what I did that worked:

  1. Using airport utilities for the Airport Extreme, I set up a guest network and password, then turned off 5Ghz so it was only a 2.4Ghz WiFi.

  2. Then I followed all the steps Anova support provided:


-Please uninstall the Anova app.
-Reset the Precision Cooker by holding the WiFi / Bluetooth light indicator (located on the touch panel) down for 3-5 seconds. You will hear a beep. Do it twice. Unplug cooker, wait the a minute then plug the cooker back in to the power outlet.
-Make sure the Precision Cooker isn’t more than 5 ft away from the router for the initial setup and all your WiFi extenders / repeaters are disabled.
-Reinstall the app, reboot your phone, enable your device’s Bluetooth, launch the app and go through the setup process again.

At this point I connected to the guest network I set up on the Airport Extreme.

-Reinstall the app, reboot your phone, enable your device’s Bluetooth, launch the app and go through the setup process again.The first try it didn’t work.


  1. Then before trying a second time I rebooted the Airport Extreme and went through the steps Anova support provided and it worked.

  2. Now I have turned on my regular/non-guest 5Ghz/2Ghz WiFi network and reconnected my phone to it. The Anova is still on the the guest network I set up. Everything is working.

Yep, most people have their 2.4GHz/5GHz having the same SSID - so the devices choose which frequency to use based on signal strength (lower frequencies carry further). The advantage to giving different names per frequency is that you can segment your devices on different networks. (eg - if the kids stream a lot of video, you could relegate them to the 2.4GHz network). 802.11AC (the newer, faster protocol) only runs on 5GHz.

Chances are, if you forgot the network on your phone, disabled the 5GHz network in the Airport Extreme, then reset the APC and setup as new on the 2.4GHz network, it would have worked fine (that’s really what you did by setting up the guest network - gave it a new 2.4GHz network to setup to).

It’s only during initial setup that your phone has to be solely on a 2.4GHz network - so the APC learns that network via the app.

What if I don’t live by an airport?

And also, that looks like a lot of steps with jargon that I don’t understand. Who do you think I am, Steve Jobs?

I’m a “plug and play” kind of guy.

1 Like

Well, thanks to the suggestion above, to connect to a guest network, I finally got my Anova hooked up to my network. This, after literally hours of attempts with different routers, phone calls with Apple, Comcast, and Anova, strings of emails with Anova (including videos of trying to set up wifi), and a warranty replacement unit that exhibited the same issue. Had I not found the guest network trick, I was going to unload the thing on Craigslist and buy a Joule, instead.

I’m quite disappointed that Anova doesn’t seem to know its product’s compatibility issues, and it’s obvious I have not been the only customer to run into this wifi connection issue. Seriously, this has been ridiculous, and quite inexcusable - joining a wifi network should be plug-and-play, and there’s no reason for such hassle. At least there appears to be a workaround, but I wonder how many other customers have simply given up; I was nearly on of them.

I’m facing the very same issue after moving ANOVA from a room without any problem(with a certain WiFi connection) to another one with a different WiFi network.
The latest uses a time capsule and every kind of device is working with it (PS4, Chromecast, Android and Apple devices) except ANOVA.
I tried every workaround read on these pages: resetting ANOVA WiFi, uninstalling app, splitting 2.5ghz and 5ghz, etc.
No way. In my opinion this is ridiculous. Is it so difficult to plug a freaking device to a WiFi connection? Anyone have experience with an apple time capsule. I think that the easiest solution is to move ANOVA to another room without the horrible time capsule.

Sorry to make your frustration more severe, but the last and current (3.0.0) version of at least the iOS app has wifi connectivity issues. Many of us with tech backgrounds have been unable to get the app to connect whatsoever (trust me, it’s the app).

See discussion over here:
https://community.anovaculinary.com/t/new-anova-app-horrible/

Someone said that an update is coming shortly - hopefully they’ve finally repaired their connectivity issues. (I’d wait until then).

But, the quick “gotcha’s” for the APC’s wifi connectivity

  • it only has a 2.4GHz Wifi radio that supports 802.11b/g/n
  • it learns the network for first-time setup from your phone - so your phone must be connected to a 2.4GHz SSID (network name) for the initial setup (after that it doesn’t matter)
  • the APC also has a very weak wifi radio - so, ideally, have it within 5 feet of your WAP (wireless access point) for initial setup
  • you shouldn’t have any spaces in your SSID or network password. Character length is 19 or less.

You could temporarily rename your 5GHz network to something else, complete the APC setup successfully, then name the 5GHz network back (the Wifi standards are actually to have your 2.4GHz and 5GHz networks named the same - that way your phone/tablet/laptop will “automagically” drop to the 2.4GHz network when the faster 5GHz network is out of range) - making things appear simpler for the end users.

All of which spells INCOMPETENCE in capital letters…

Want to hear something really sad? The chipset that they used has always supported WPS - for some reason, they never wanted to enable it in their firmware.

I wasn’t particularly looking forward to hearing something sad, no. :wink: The thought of Anova’s programmers going anywhere near anything security-related gives me the shivers though, considering past performance…

Heh, maybe they discovered a massive security exposure with their cloud and purposefully broke the wifi connectivity so none of their users could get hacked. :wink:

1 Like