Precision Cooker WI-FI connection issues

So seems that this really is the case… I will not change my SSID. So back it will go.
This should be an easy fix or am I wrong?

Hey, yes unfortunately there is no easy fix right now. We have the precaution set up because we found if people had a space in the their password it dramatically decreased connection rates.

I wish there was some way to work around it, but right now there isn’t :slight_frown:

My password was not the issue. It’s was the SSID network name,
For example mine was “Mark network” not quotations , I was told it should be “marknetwork” and again for most it shouldn’t be an issue to change it.
But the fact I built a smart house with many devises it is an issue for me, but I could be one of a select few.

So after two cooks without issues today I set up the PC and not even before the water got up to temp my PC disconnected I never received a note the water was ready for cooking. I happened to pass by and looked at it. I was already 8 min late for my cook.
Then after peaking around unnoticed my wifi disconnected from the PC. I tried to reconnect it but no luck.
Just when I thought all was good this happens. Uggg so frustrating

I’m so sorry, this sounds like a reoccurring issue. Contact support at and they can help you troubleshoot or get a return if necessary :slight_smile:

I purchased the Anova wifi for a reason , not to return it. I want what I paid for unless you think it is defective and I can get a return then ok but I am not looking for a return.

We have 1-year warranty so If it is defective you would return the one you have and in exchange get a functioning device :slight_smile:

I’ve got the latest Anova Wi-Fi app, and am trying to connect my Precision Cooker to it, but I’m having some trouble. The app finds the cooker, and finds the 2.4 GHz Wi-Fi, but connecting to it still fails, even though the cooker is placed right next to the Wi-Fi access point during the entire process.

The passkey for the 2.4 GHz network consists of all 7-bit ASCII, so no special characters, so it just about meets my barre minimum security requirements: Minimum 10 characters, mix of capital, lowercase, punctuation, and numbers. There are also no spaces in it (which I saw comments from people having issues with).

I tried deleting the app, redownloading it, and resetting the cooker, as per the support article, but still no go.
What else can be the problem?

And yes, I’ve got my SSID visible too.
Please don’t expect me to compromise my Wi-Fi security with a less secure password just so I can connect the cooker. I use my home Wi-Fi to VPN in to work, and because of this, my Wi-Fi has to adhere to corporate requirements. If the password is the issue, I’d rather wait for a firmware that has better support for Wi-Fi passwords.

Hey @finn, Hmm, that is super strange, it looks like you have done all the right things as far as trouble shooting. I would recommend sending an inquiry to, and I will ask on Monday to see if there is anything else you can do :slight_smile:

Hi, I dont have password on my Wifi network. Is it true that i cant connect it to wifi network unless i secure my network. I cant do it for some reasons, so there should be options also for non secured wifi networks…

I think a good solution would be if your WAP supports having a guest network (these are unsecured). Just configure your guest network with your current network’s SSID and it should work for all of your existing devices - then create a secure network.

Are you rural? (maybe nearest neighbour is a long ways away?) Otherwise, seems quite odd to not be securing your network.

Just got my new WiFi Anova today and I also can’t connect it to my wifi (bluetooth pairing with my phone works fine).

@finn did you ever get yours working? You mention your pw has punctuation, I feel like that usually counts as special characters in a password context even though it’s still plain ASCII. My pw also has punctuation so I’m wondering if that is the issue.

There’s one line on this help page that says “Ensure that your password is between 8 to 18 characters, and contains no special characters.”

@Bill or HunterC can you confirm whether or not this is the issue, are characters like ! or & allowed in wifi passwords?

UPDATE - I spun up a guest network with no special chars in pw and can connect my Anova to that fine, so it seems very likely the special chars is the issue. Honestly it’s a pretty ridiculous requirement and makes me think that if you’re fine with just casually breaking things for users in an unexpected way like this, what other corners have you cut or security vulnerabilities are there in the Anova? Have some pride in your work folks. Please get this fixed.

^ @HunterC as well, can you look into this. (I could only mention 2 users in a post)

This is still am issue with my phone. It is an adroid samsung s7. Until you fix it, my soys vide is a door stop…

Believe it or not, but you don’t need the app to use it. You can just use the dial to set the temperature and hit the start button to kick off the cook. (use any timer you like for the cook…I’m sure you have one on your phone) :slight_smile:

Hey, thanks for the updates, and sorry for my late reply. But yes, it looks like the issue was the special characters. I know that is a really frustrating requirement. We are always updating and improving the app, so I will pass this on this feedback to the team. I will let you know if there are any further updates that address this issue.

Has this been fixed, because i still can’t connect via WiFi? Keeps telling me I’m using the wrong password, which I know isn’t true. I’ve sent 2 emails to you and still no response. No one has ever had trouble connecting to my WiFi and I had many people do so over the holidays.

I can connect via Bluetooth, but this option is worthless IMO. You have to leave your phone right next to the cooker, That’s not practical. In fact, I received the Bluetooth only cooker for Christmas and exchanged it ( plus $50) for the WiFi version. I’m starting to question that move.

Well, considering this is your first post on this topic, you really should be clear what platform you’re using (and which version of the app).
If it’s saying wrong password - you did read some of the posts above before posting, right? You saw that special characters can’t be used?
As a workaround, you can always create a guest network with a simple password to connect the Anova to.

btw. Why would you need to keep your phone near to the PC when using the bluetooth version of the app? It’s not like it stops cooking if you go out of range. :slight_smile:

No special characters, Android 5.1.1 and app ver: 0.0.178. Yes, I’ve read many of the topics here and tried everything that I thought would help. .

Maybe it doesn’t stop cooking, but why spend $50 more for WiFi if it can’t be used?

I do want to add, that it maintains temperature extremely well, so from a cooking standpoint it certainly does the job.