Wifi + Bluetooth Model Connection Issues

I decided to try out my anova Wifi+Bluetooth model today. Plugged in the machine, fired up the app and it paired no problem then I did Wifi connect and that worked as well, even though I have a 25 character password. Then as soon as I try to set anything or do anything the app loses connection and cannot reconnect. But the anova is still connected to my network, no signal issue at all.

First I finally saw there is a problem with the Wifi on the current android app, why is this not posted to the front page of the site so I didn’t have to dick around for an hour trying to fix a known issue?

Second is if it has bluetooth & Wifi, how can I just force it to use the bluetooth until the app wifi is fixed?
I have searched for this and I am not finding an answer.

Hi @auxout, That is super odd, I will ask around though. And you should be able to just connect to bluetooth as the connection process is two steps: first pairing with bluetooth and second connecting to wifi. If that is not the case let me know and I will see what info I can find :slight_smile:

So I just went to try it to verify. Unpaired it and unplugged it and plugged it back in, it pairs no problem. Then there is no way to NOT do the wifi pairing i can see. If you go back it cancels setup, if you turn off phone wifi it says to turn it on. So I continue and it successfully completes the wifi paring and shows the temp and the unit is running correctly. As soon as I hit a command, set temp, or start or stop the wifi connection blinks on the app and loses connection. I try 2-3 times and then it loses connection on the app and will not reconnect. So I have no idea why I cannot at least use bluetooth, but the unit is still connected to my wireless network as well.

I just took a look. You only have the one app in the Google Play store. In the Apple App Store, we have two - Anova Culinary and Anova Wifi (so, if you have something funky going on with wifi, you can use the bluetooth version of the app).

@HunterC - might not be a bad idea to have both flavours in the Google store as well to have an easy workaround.

1 Like

Thanks @fischersd, really good point. @auxout I would recommend contacting support@anovaculinary.com, where my teammate Peter can help you trouble shoot, and if we find something is wrong with the device we can help you return it there :slight_smile:

@fischersd Interesting, well it so happens my work phone is an IPhone so I may try that to see whats going on with it.
@HunterC I will do that, thanks.

@fischersd @HunterC

Well I got the unit replaced and here I am again with exact same problems. I can watch it connect and disconnect from the app repeatedly, it will sit there connected until I press start cook then disconnect. Does the android app and or wifi and or bluetooth actually work for anyone? It seems like tons of people are having these issues but I see no clear answer and no way to seriously troubleshoot the issue. Why can I not connect using bluetooth when I am standing right next to the device? I can look at my network and see the device never loses connection to the wifi network. So hazarding a guess it seems like the app is the problem, that or the device firmware responsible for commands. It just told me the water is ready so it reconnected long enough to do that.

Hi @auxout, we have found some bugs after the most recent app release that could be affecting your connection. We are working on fixing them now, so make sure you have the most recent update, and that might help fix some of these issues. Let me know if you are still having issues after the next update and we can look into it more.

I have version 0.0.180, which appears to be the newest. When is the next update, I paid a premium for bluetooth+wifi connectivity which to date seems completely non-functional on android.

@auxout The beta-app has been rolled out! I suggest you to become a beta-tester and check it out. I think you’ll like it - you can connect via Bluetooth or via Wifi, and new design is awesome!

@apples Sure, but I’m not seeing any information on how to do that? Looked here, facebook, twitter, seems to be fairly well hidden.

@auxout, open Anova app in Play Market on your phone and scroll down - you’ll find beta instructions in the bottom.

Thank you so much for this. I was into this issue and tired to tinker around to check if its possible but couldnt get it done. Now that i have seen the way you did it, thanks guys
with
regards
https://akinator.ooo/ https://kik.onl/ https://xender.vip/

Not good enough! Date now 26/05/2019 6 months more or less since this issue was raised.

I too have paid for the option of both Bluetooth and wifi.

First I set it up it detected my 5g you would have thought it would have been designed to know the difference, not even an option to chose network just assigned the network, though at the same time stated it needed 2.4g so why not locate the 2.4 No I had to go into router switch off 5g uninstall app and start again. what if I did not know how to do that?

fine, I thought at least it is sorted.

I was wrong it almost got to temperature then lost connection, I checked router it was still connected. checked to devise it states it is not. Uninstalled again, Unassigned even deactivated wifi on phone. NO option to use the Bluetooth. I thought it was supposed to detect Bluetooth first, it does not even have a Bluetooth icon just a stupid flashing wifi one. this toy is not cheap and when we pay for both Bluetooth and wifi options they should both work.

It is stated the iPhone has both wifi app and Bluetooth app yet android only has wifi, what kind of planning is that.

It is stated that the culinary app is the Bluetooth app wrong again when I downloaded the only app showing for as it starts asking for wifi and when I try and bypass that with my phone practically sitting in the water with it it still cannot detect Bluetooth.

there is a touch screen on top for wifi why not one for Bluetooth, are you perhaps misleading customers and that is why Bluetooth app is no longer available, just a thought.

The frustrating thing is my friend who bought the Bluetooth version (He uses Android) and was the one who convinced me to buy this piece of crap.

Is this going to be fixed before my warranty runs out, all day I have been messing around doing this, I charge £600 day rate for my photography work that is a day wasted.

Have you reached out to customer support?

I gave up on it ever working, it just isn’t good, it doesn’t work I don’t think it ever will. I have exchanged the unit, tried the beta, tried resetting the app, etc, etc. Customer service says there will be updates or try the new beta version of the app, it has made 0 difference. The wifi connectivity is garbage and the bluetooth isn’t far behind, still can’t even tell it to default to bluetooth seems to default to wifi all the time… I hardly use the thing anymore because it is so unreliable and when I do I use a standalone timer and don’t even bother with the app, this is on android, its the same. It’s 2 years later for me, would never recommend buying it for the connectivity + app, works fine manually.

Same here

I just purchased one of these and already regret wasting my money on it. I’m going to return it tomorrow and just buy a cheap one on amazon. At least the cheap one will work as advertised and not have connectivity issues like this POS.

bluetooth keeps dropping out. constantly need to reconnect to wifi. slow. laggy. rubbish.

thank you so much for clear this issue i have been wondering about this issue!

thanks, GBWhatsApp