No ideas! It just comes with a long beep and doesn't functions!

Hi, can anyone help on my on issues?
I am just newly to start my anova, it comes with a long beep all the time!
the water is already above the MIN water level and it has been fixed!
I have no ideas and Anova do have much supports on the errors.
I sent email yesterday and no one replied me. FAQs is too simple, doesn’t cover much!

Please, please, please help!

Hi!

I’m so sorry that is happening. The first thing to try is unplugging and replugging in your unit to restart it. If that doesn’t work and it is still beeping, please contact your support team at support@anovaculinary.com to begin the replacement process.

Also fill out this form to start the process if you need: https://anovaculinary.com/pages/returns/

That definitely shouldn’t be happening, I’m so sorry, but we will do everything we can to get you cookin’ asap!

Solution that worked for me: Run the unit in a 50/50 vinegar and water solution for 10 minutes. Take this solution and add it to your water bath for cooking and toss in a tablespoon of salt. Detailed issues are below.

I had this issue too, I raised and lowed the water between the max and min lines with improvement. Unplugged it and plugged it back in about 8 times and the thing would still error out and just let out a long beep. Starting and stopping would work for only maybe 60 seconds before stopping again.

Searching the internet didn’t provide much help other than contact support and return the unit. This wasn’t an option as I had lobster and filet mignon in cooking and I was only 20 minutes into the cook. Note that I had no issues and clean and dry the unit after every use.

The only thing that oddly helped where the steps that I found in this blog post: http://www.jordanviray.com/2015/10/anova-sous-vide-low-liquid-warning.html

This person stated that he had scale build up, something I did not have on my unit. With nothing to lose I put my Anova in a new container and put all the vinegar I had in the house in to it to make a 50% vinegar water solution and ran it for a bit (10 minutes or so). The thing ran 100% fine with out issue or error.

I removed water from my pot I was cooking in so I could put the vinegar solution into the cooking pot since that seemed to work. This ran for about 10 minutes and then let out the long beep for more water (even though it was about 1 cm from max fill). With nothing else to lose and not knowing how the Anova determines water level I thought maybe it has something to do with electric current in the water. So I tossed in about a tablespoon of Mortons Sea Salt into the pot and turned it back on and it worked for hours allowing me to finish cooking my meal.

No clue why these steps worked, but they did. Hopefully my unit continues to work without issues.

1 Like

Glad this worked for you, it is good to know!

100% fix